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1. Software Overview 

1.1. Features 
Welcome to use the Ana Offline Analysis Software, which is used to open offline 
waveforms recorded by the data collection software PLC-Recorder and perform data 
analysis. 

Main Features: 

 Rich note and annotation features, allowing for quick analysis and annotation of 
Bool tags. 

 Powerful numerical and logical search, with fast edge positioning. 

 Powerful multi-file processing capabilities: includes fast browsing, one-click 
connection, multi-file merging, and matching browsing functions etc. 

 Expression tags: You can use existing recorded data for mathematical and logical 
operations to generate virtual series and initially explore the value of the data 
(supports over 30 functions). 

 Drag-and-drop operations: You can select series, set various parameters, adjust 
series order, adjust series height, and co-axially display multiple series (numerical 
values, Bool tags, strings, etc. can be mixed freely) directly from the main 
interface. 

 Powerful zooming features: Y-axis zooming for series, area zooming through 
drag-and-drop, step-by-step or full rollback, and movement in the XY direction etc. 

 Data export: Data can be partially or fully exported to a spreadsheet file. 

 Image output: Automatic screenshot with comments and annotations can be taken, 
and parts that extend beyond the screen can also be copied using the long image 
feature. 

 One-click series color setting for a comfortable color scheme. 

 Quick tag filtering, marking, and statistical functions. 

 Users can open a separate software for each file, without interference. 

 For 64-bit operating systems, large memory can be utilized for handling huge files. 

 Waveform data pre-processing function: removal of abrupt points. 

 Channel time offset function: aligning waveforms between different channels. 

 Powerful navigation function: You can navigate using any series and quickly locate 
the target area. 
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1.2. Notice 
! The contents of this manual may differ from the actual interface and functions; 

your understanding is appreciated. 

! This software will not perform any communication actions. If you notice 
abnormal behaviors such as advertisements or other links that may threaten 
network security, please obtain this software from official channels. 

! The company is not responsible for any losses incurred during the use of the 
software. 

! If you encounter issues within the functionality of this software: please refer to 
this manual. If the issue remains unresolved, check the official website to see if 
the software has been upgraded and try the latest version. If the issue still 
cannot be resolved, please join the QQ group to report it, or email the support 
address below (service@HiddenMap.cn, including problem description, fault 
information file, and waveform file at the time of the issue). 

 

  

mailto:service@HiddenMap.cn
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1.3. Support 
Official Website provides complete services such as downloads, upgrades, purchases, and 
technical support. 

 
Email：  service@HiddenMap.cn 
Web：  www.HiddenMap.cn 

All rights reserved. 

Shanghai HiddenMap Intelligent Technology Co., Ltd 

2019 

mailto:service@HiddenMap.cn
https://www.hiddenmap.cn/


 

 

2. Terms and Basic Concepts 

2.1. Terms 
Terms Meaning 

Channel 

Channels are divided into two types: external channels and expression 
channels. 
External channels correspond one-to-one with data sources, the most typical 
being each device in PLC-Recorder. 
Expression channels are built-in channels in the Ana software that store all 
tags that need to be displayed. 

Tags 
Tags include two types: external tags and expression tags; the data for 
external tags comes from external channels. Expression tags may come from 
external tags or may be tags used for secondary calculations. 

Model Includes all expression tags and their display and combination methods. The 
file extension for model files is ".apj". 

Cycle Polling cycle of the tag. 
Absolute Time Acquisition time recorded in hours, minutes, and seconds. 

Relative Time The recorded trigger time is 0:00, with the time difference measured in 
seconds. 

2.2. Data Type and Length Correspondence (Partial) 
Supported Types by 

This Software Length Controller Data Type 
(SIEMENS)* 

Controller Data Type 
(AB) 

bool (Bool tags) 1 bit Bool BOOL 
Byte 

1 byte 
Byte, USint Byte 

SByte Sint SINT 
Char (ASCII characters) Char  
WChar (Extended 
characters) 2 bytes, 

single 
word 

WChar  

short (Int16) Int INT 
ushort (UInt16) Uint, Word  

int (Int32) 4 bytes, 
double 
words 

Dint, Time DINT, TIMER, COUNTER, 
CONTROL 

uint (UInt32) UDint  
Float (real) Real REAL 
long (Int64) 

8 bytes 
Lint  

ulong (UInt64) ULint  
Double LReal  

String variable 
length 

String, Char array String 

Wstring (Extended 
string) 

variable 
length 

WString, WChar array  

*: The supported data types vary among different SIEMENS series; please refer to the 
relevant manuals for details. 

2.3. Supported file types 
This software supports. ihm data files generated by PLC-Recorder, which are in 
compressed format. The software also supports. atd (a text format file) and power 
system waveform files (COMTRADE format). 

 
 



 

 

3. Installation and Operation 

3.1. Required Environment 
This software is based on the .NET 4.0 framework. 

Supported Operating Systems: Windows XP SP3 and above, automatically adapting to 
both 32-bit and 64-bit (with a larger operable data volume in 64-bit). 

Required Software 

 XP System: .NET 4.0 needs to be installed (sometimes WIC software needs to be 
installed first to install .NET 4.0; the software can be found in the supporting 
software directory). 

 For other systems, please install or enable .NET features. 

3.2. Installation Process 
This software is deployed with PLC-Recorder; please use the Setup.exe in the software 
directory to configure file associations. 

The main interface is as follows: 

 
Figure 3.1 Main Interface 

3.3. Authorization 
This software has no authorization restrictions and can be used freely. 



 

 

4. Expression Tags 

4.1. Brief description 
To enhance computational and analytical capabilities and to initially explore the value of 
the data, this software has added the expression tags feature. All expression tags are 
placed in a single expression channel and appear in the table at the bottom. 

The red dashed box 1 in the figure below displays the external channels and all available 
external tags. 

The expression tags in the red dashed box 2 can be edited by clicking on the expression 
cells or through the menu "Tools" -> "Edit Expression tags". 

 

Figure 4.1 Expression Tags 
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4.2. Editor 

 
Figure 4.2 Expression Editor Window 

The left side of the editor window shows the tag tree and the list of available functions, 
while the expression area on the right is where you input formulas. The tags and 
functions to be referenced can be dragged directly from the left side or input manually 
in the specified format. 

Keywords in the expression are automatically distinguished by color: functions, 
referenced variables, operators and constants. 

Formulas must follow certain syntax; please refer to Appendix 1 for details. 

The syntax check button can identify possible errors in the expression and perform a 
simulation calculation to initially determine if the formula is valid. Syntax checking 
does not require manual operation; it will be automatically performed when saving tags 
or exiting the compilation. 

If there is an error in tag checking, the tag will be marked (hovering the mouse over the 
erroneous cell will display the error information). Tags with errors will not undergo data 
calculations, so series cannot be displayed on the main interface. 
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Figure 4.3 Example of an Expression Tag Error 

4.3. Classification of expression tags 
Based on processing characteristics, expression tags can be classified into four types: 
constants, single-reference tags, direct tags, and multiple-reference tags. 

 A constant is an unchanging value, represented at the far left and far right points in 
the graph generation. 

 Single-reference tags: expression tags that are related to only one external tag. The 
X coordinates of the data points for these tags correspond one-to-one with the X 
coordinates of the data points for the referenced external tag. The expression tags 
e1, e2, eb1, and string0 in the figure below are all single-reference tags. 

 Direct tags: a special form of single-reference tags that are directly equivalent to 
external tags. The expression tags e2, eb1, and string0 in the figure below are all 
direct tags. Note: String tags can only be displayed through direct tags and 
cannot undergo other calculations or combinations. 

 Multiple-reference tags: tags that are related to multiple external tags. To minimize 
combination distortion, if the referenced external tags belong to different external 
channels, their data points will be denser than those of any single external tag and 
will be evenly spaced in time. The expression tag n in the figure below is a 
multiple-reference tag. 
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Figure 4.4 Different Expression Tags 

4.4. Creation of expression tags 
Method 1: Add in the Expression Editor. 

Method 2: Drag the external tags from the left side directly into the chart on the right to 
create. 

Method 3: In the tag information form at the bottom, right-click and select "Add Tag" to 
create. 

4.5. Deletion of expression tags 
Method 1: Delete in the Expression Editor. 

Method 2: In the tag information form at the bottom, right-click on a tag and select 
"Delete Tag" to remove it. 

4.6. Save 
Expression tags are only saved in the analysis model and are not stored in the data files; 
they can be applied to all data files that match the format. 

 

Reference: 

Demonstration of Expression Operation 

 

http://hiddenmap.cn/files/video/00%20%E6%8A%80%E5%B7%A7/V2.0%20Ana%E5%8F%98%E9%87%8F%E7%9A%84%E6%B7%BB%E5%8A%A0%E5%92%8C%E5%88%A0%E9%99%A4%E6%93%8D%E4%BD%9C.mp4


 

 

5. Display Area 

5.1. Division of the Display Area 
 

Figure 5.1 Main Interface for Historical Data Display 

5.2. Software Title Area 
The software title includes the software name, model file name, data file name, and 
model file. 

The model file includes the configuration content for channels and tags; please refer to 
the configuration section for details. Data files includes the current configuration 
content and historical data. 

  

1 

 

 

2 

 

 

3 

4 
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5.3. Function Options Area (Area 1) 
This area includes menus, shortcut function buttons, file list boxes, and more. The 
shortcut function buttons have tooltip hints that provide a brief description of their 
functions. Some function buttons can be toggled on or off via the menu "View" -> 
"Show tools". The following will introduce the functions of some buttons, while topics 
like search and annotation will be covered in later chapters. 

Clicking  opens the expression tag configuration interface. 

Clicking  opens existing analysis model. 

Clicking  saves the changes to the model. 

Clicking  shows grid lines. 

Clicking  will automatically assign the color of the series once (Series Color 
Automatic Setting: Enable the automatic color setting function through the menu 
"View" ->"Auto color for new series". When adding a new series, the color is 
automatically assigned according to the series number in the area. The color of the 
existing variables in the area is not modified. When dragging the series between areas, 
the color remains unchanged. The "Auto color once" button is still valid, and the color 
can be reassigned automatically.). 

 

Clicking  will adapt the Y-axis of all series, and the adaptive effect is related to the 
menu option "View" -> "Select Global for Y-axis". 

Clicking  will maximize the display range of the X-axis. 

Clicking  will undo the last zoom operation. The software will remember each local 
zoom operation and allows for step-by-step undoing. 

Clicking  will reset the zoom to the original state (no zoom). The zoom will reset 
to the original state during operations such as adding or deleting series and opening new 
files. 
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5.4. Tag Tree (Area 2) 
This area lists all valid tags according to channel numbers (devices). The icon 
determines whether it is a Bool tag; opening a tag allows you to view the address, 
specific type, and comment. 

 
Figure 5.2 Tag Tree and Operations 

Entering characters or text in the filter box will quickly filter all tags whose names 
contain the specified text. The numbers indicate the discovered tags and the total 
number of tags. 

Dragging the right border of this area with the mouse can change the size of the area. 
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5.5. Group (Area 2) 
Tag information is displayed by group, with ungrouped tags categorized as 
"Ungrouped". 

 
Figure 5.3 Tag Tree and Operations 

Tags within a group can be dragged to the right series area just like in the tag tree. 

You can also drag the entire group into the right area, which will automatically skip any 
tags that already exist. 
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5.6. Series Area (Area 3) 
Recorded data is presented in the form of series within this area. It includes multiple 
independent charts (light gray background). 

To the left of each chart is the region adjustment function area, which includes options 

for adjusting the region's position ( , ), stretching the Y-axis ( , which can be 

clicked or held for continuous adjustment), shrinking the Y-axis ( , which can also 
be clicked or held for continuous adjustment), and vertical panning (dragging the 
Y-axis), among other functions. 

The bottom of the series area has a common X-axis, and after local zooming, you can 
pan left or right by dragging the X-axis. 

There are two types of series: numerical and Bool. Numerical series have functions for 
stretching, compressing, and panning, while Bool series can only be scaled in the X 
direction. 

 
Figure 5.4 Left Control Area 

5.6.1. Adjustment of Numerical Series Height 

 
Figure 6.5 Adjustment of Numerical Series Height 

When the mouse moves to the red box area at the bottom of the chart, if that area 
contains numerical series, the cursor will change to a horizontal line. By holding down 
the left mouse button, you can drag up or down to adjust the height of the series, and the 
adjustment will take effect upon releasing the mouse button. 
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5.6.2. Local Zoom 

In the non-annotation state (with no annotation functions selected), left-clicking and 
dragging to select a gray area of the series (avoiding the legend) will perform a local 
zoom. 

 
Figure 5.6 Local Zoom 

After local zooming, all series will also have their X-axis enlarged. Clicking  will 

apply adaptive scaling to the Y-axis of all areas. Clicking  will restore the X 
direction to its original value. 

Right-clicking within the area and selecting "Y:100%" from the menu will apply 
adaptive scaling to the Y-axis of the individual area. 

Right-clicking within the area and selecting "Y Properties…" from the menu allows you 
to set different Y-axis ranges or functions for the area (adaptive or fixed range). 

 

Figure 5.7 Y-Axis Properties for the Area 

You can continue to select areas for local zooming or perform zoom-out operations 
afterward ( , ). 

5.6.3. Moving Series Between Charts 

Dragging the legend of the corresponding series within the chart allows users to move 
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the series between charts. If released in an existing chart, the series will be added to that 
area, enabling the function of multiple series sharing the same Y-axis. If released 
outside the chart or in the X-axis area, a new chart will be created. 

5.6.4. Change the Order of the Series in the Area 

Series are divided into two types: Bool tag and numerical. The tag types represented as 
Bool tag include: BOOL, Discrete, String, etc. The others are represented in numerical 
form. 

If a chart has multiple series of different types, the display order can be changed. In the 
"Tag information" table, right-clicking on a tag row will bring up a menu that allows for 
operations such as adjusting area order, changing tag positions, and closing series. 

 

Figure 5.8 Tags Position Operations 

5.6.5. Delete Series 

Method 1: Hide the series 

In the list at the bottom, deselect the display option for that tag, and the series will be 
closed. This method does not affect the data annotation and statistical functions (see the 
following chapters for details). 

Method 2: Completely close the series 

Right-click on the series legend and select "Close the series" to remove the tag from the 
display list, achieving a complete closure. 

Method 3: Close area 

Right-click in the chart and select "Close area" to completely close all tags within that 
area. 

5.6.6. Shortcut Operations for the X-axis 

Method 1: Dragging the mouse on the X-axis will move the window accordingly. 

Method 2: Quickly select a new area from the navigation table (See subsequent 
contents). 

Method 3: Use the X scrollbar for zooming in and out, dragging, and paging etc. 

Activate the X scrollbar through the menu "View -> Show X scroll bar" to perform 
various operations; the navigation and series windows will move and scale accordingly. 
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Use the menu "View -> Options" to switch the functions of the + and - buttons to suit 
your preferences. 

 

Figure 5.9 Effects of the X Scrollbar 
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5.7. Tag Information Table (Area 4) 
This area includes three sub-tables: the Tag Information Table, Markers, and Statistics. 
The height of the area can be adjusted using the top border. 

5.7.1. Tag Information Table 

The Tag Information Table presents information such as display control, name, 
expression, comment, decimal places, units, and color for each tag. 

The display options allow users to control whether to show series, with the ability to 
select individually or in batch. 

 

Figure 5.10 Tag Information Table 

Correspondence between tags and charts: 

When a row in the table is selected, all tags in the corresponding chart will be indicated 
in gray. After selecting a chart with the mouse, the related tags in the table will also be 
indicated in gray. 

If there are too many series and a scrollbar appears, some series may not be displayed 
automatically. In this case, clicking on the series legend will automatically scroll the 
corresponding entries in the bottom table into view. 

Automatic decimal adjustment function: When the expression tag type changes from 
integer to floating-point, the decimal places will be automatically set to 2. When 
converting from floating-point to integer, the decimal places will be automatically set to 
0. 
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Figure 5.11 Correspondence Between Table Entries and Charts 

5.7.2. Marker Information Table 

Opening the table displays two movable X marker (red dashed lines) in the series area: 
X1 on the left and X2 on the right. The table shows the corresponding time values, time 
differences, series values, and series differences. Moving the marker will change the 
values accordingly. 

When dragging the marker, the values will change in real time. 

Precise marker control: Select the marker and use the left and right keys to move it pixel 
by pixel. 

Use the menu "View -> Options" to adjust the block size to suit your preferences. 

According to the settings in the Tag Information Table, the first tag is displayed in 
binary format. 

Tags listed in the Tag Information Table will still be included in statistics, even if the 
series are not displayed, but their background will be gray to indicate this distinction. 

Right-clicking on a tag allows users to change its display format. The available options 
for display formats depend on the tag type. Bool type has no other format; floating-point 
and double types can also select scientific notation, while other types can choose 
hexadecimal or binary formats for easier viewing of bit or byte values. 

 

Figure 5.12 Marker Information Table 

If relative time is selected, the values at X1 and X2 will display the time differences 
relative to the trigger moment. 

Correspondence between tags and charts: 

When a row in the table is selected, all tags in the corresponding chart will be indicated 
in gray. After selecting a chart with the mouse, the related tags in the table will also be 
indicated in gray. 

5.7.3. Statistics Information Table 

Opening the table will display two movable X markers in the series area (X1 on the left 
and X2 on the right), with statistical information between the markers shown in the table. 
For numerical series, the displayed statistics include Maximum, Minimum, Average, and 
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Std. Deviation. For Bool series, the displayed statistics include pulse count, interval 
frequency, and average cycle information. Moving the marker will change the values 
accordingly. 

When dragging the marker, the values will change in real time. 

Precise marker control: Select the marker and use the left and right keys to move it pixel 
by pixel. 

Tags listed in the Tag Information Table will still be included in statistics, even if the 
series are not displayed, but their background will be gray to indicate this distinction. 

 

Figure 5.13 Statistics Information Table 

If relative time is selected, the values at X1 and X2 will display the time differences 
relative to the trigger moment. 

Correspondence between tags and charts: 

When a row in the table is selected, all tags in the corresponding chart will be indicated 
in gray. After selecting a chart with the mouse, the related tags in the table will also be 
indicated in gray. 

5.7.4. Adjust Column Width 

Some columns allow width adjustments, which can be done by dragging the header row. 
After adjusting the width, if the window size is changed, each column will be 
proportionally adjusted to fill the available width. 

5.7.5. Navigation Table 

Select the navigation table, then choose any chart to navigate to that area. 

Select the red box to adjust its size and position; the content in the corresponding area 
will change, and the time axes of other areas will also adjust accordingly. 

Zooming in and out of each graphical area will have the red box indicate the current 
window of the navigation area. 

In the absence of dragging, quick rulers, annotations, or other active states, clicking on 
different charts will switch the navigation window to the corresponding chart. 
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Figure 5.14 Navigation Table 
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5.8. The Information at the Bottom 
The left side at the bottom displays the maximum number of points for each channel 
(maximum points). The right side shows the x value at the mouse click and the y value 
in the corresponding chart. 

5.9. Display Format Modification (Options) 
You can open the options page for personalized display settings through the menu 
"View" -> "Options". 

 

 

Figure 5.15 Options Page 

 



 

 

6. Shortcut Operations for Bool Tags 

6.1. Quick Ruler Function for Bool Tags 

Click  button or use the menu "View -> Quick ruler" to enable this function. Then 
select the bottom ruler or statistics function; two red rulers will appear. Click any Bool 
tags area, and the ruler will automatically position itself at the left and right edges of 
that tag's state, while the statistical or annotation data for all tags in the table will change 
accordingly. 

This feature can greatly facilitate segment analysis of a range of data. 

 
Figure 6.1 Demonstration of Quick Ruler Function 

6.2. Quick Annotation Function for Bool Tags 
It can quickly measure and annotate the pulse length of Bool tags (excluding 
waveform-like String tags of Bool tags), as detailed in "Annotation for Bool Tags". 

6.3. Bool Tags are displayed as bar shapes. 
Enable this feature through the menu "View -> Bool bar"; high levels of Bool tags will 
be displayed as solid shapes (see Figure 7.1), making it easier to view and distinguish 
the status of Bool tags. 

6.4. Bool Height Adjustment 
Select the height of Bool tags through the menu "View -> Bool height"; in conjunction 
with font size adjustment, this allows for nine levels of height adjustment. 

Download Operation Tips Video. 

https://hiddenmap.cn/files/video/00%20%E6%8A%80%E5%B7%A7/Ana%E5%BC%80%E5%85%B3%E9%87%8F%E6%93%8D%E4%BD%9C%E6%8A%80%E5%B7%A720210117.mp4


 

 

7. Search Function 

Click the search form on the left to access the search interface, where you can set 
conditions and perform searches. 

7.1. Search Condition 

  
Figure 7.1 Search Condition Setting Interface 

The tag name list displays all available tags, with expression channel tags listed first, 
followed by external tags sorted by channel and tag numbers. 

For numerical tags, only value searches are allowed. For Bool tags, searches can also be 
conducted based on the duration of the state. Value 1 represents True, while value 0 
represents False. 
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7.2. Search Mode 

Then click on  to search backward from the cursor, or click on  to search 
forward. 

If the bottom table is on the "Tag Information" or "Navigation" page, the cursor will 
stop at the first found point, change to a red cursor, and update the current value in "Tag 
Information". 

If the bottom table is on the "Markers" or "Statistics" page. Before performing a value 
search, you need to select a marker for positioning. When performing a time span, there 
is no need to select a marker; the dual cursor will automatically position itself at the 
pulse that meets the conditions. 

 
Figure 7.2 Time Span Illustration 

Edge Detection Function: "Normal" indicates non-edge detection. Other options can 
search for specified edge types. For numerical tags, there are three types: "Entry edge", 
"Left edge", and "All edge". For Bool tags, there are three types: "Rising edge", "Falling 
edge", and "All edge". 

 



 

 

8. Data Pre-processing Function 

During the analog signal collection in PLC, interference situations may sometimes occur, 
leading to sudden changes in results, as shown in the figure below: 

 

Figure 8.1 Existence of Mutation Points in Waveform 

From the menu: "View -> Options -> Data", you can set the parameters for deleting 
mutation: 
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Figure 8.2 Delete Mutation Configuration Window 

When the rate of change of the subsequent point exceeds the set change threshold, and 
the total change amplitude exceeds half the difference between the maximum and 
minimum values, the subsequent point will be considered a mutation point, and its value 
will be replaced by the previous value. 

Checking "Enabled" will process the data and eliminate mutation points, resulting in the 
effect shown in the figure below (the extreme values of the two waveforms have 
become reasonable). After enabling the pre-processing function, the label "Del. 
mutation" will appear in the lower right corner. 

Checking "Use to integer" will also eliminate mutation points for integer data; if not 
selected, only floating-point and double-precision numbers will be processed. 
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Figure 8.3 Waveform After Removing Mutation Points 

 



 

 

9. Annotation Function 

 
Figure 9.1 Main Interface of Annotation Function 

Features quick annotation for Bool tags, point annotation, text annotation, and range 
annotation. At any time, only one annotation method can be selected, or none can be 
chosen (by clicking on an already selected button), allowing for other graphical 
operations. 

Since the annotation are associated with the data, some annotations can be saved within 
the data file, allowing for recovery when reopened. If an annotation is associated with 
multiple reference tag data points, it cannot be saved. 

Description 
The local zoom feature conflicts with the annotation function; therefore, local zoom can 
only be performed when the annotation function is not selected. 

9.1. Annotation for Bool Tags 

Used to quickly determine the width of Bool tags  purse (unit: ms). 

Click  button, then click on the Bool tag series to label the duration of this state. 
The effect is as follows: 

 
Figure 9.2 Pulse Wide Illustration 
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9.2. Point Annotation 

Click  button, then click the mouse near the target point to display a note pointing 
to the selected point. Double-click to edit the note's content, and drag to change its 
position. The effect is as follows: 

 
Figure 9.3 Illustration of Point Annotation 

9.3. Text Annotation 

Click  button, then click on the series with the mouse to display a text annotation. 
Double-click to edit the annotation content, and drag to change the position of the 
annotation. The effect is as follows: 

 
Figure 9.4 Illustration of Text Annotation 

9.4. Range Annotation 

Click  button, then drag from the starting point to the endpoint on the graphic to 
create a range annotation. Moving the vertical line left or right can change the 
annotation area. Moving the horizontal line up or down can change the position of the 
text. When annotating, the text displayed shows the duration, which can also be 
double-clicked to change its content (Note: If the vertical line is moved again, it will 
revert to the time content). The effect is as follows: 
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Figure 9.5 Illustration of Range Annotation 

9.5. Delete Annotation 
Each type of annotation can be selected, and right-clicking the mouse will show the 
"Delete the annotation" option, allowing you to remove the selected annotation. You can 

also click  button to delete all annotations. 

 
Figure 9.6 Illustration of Annotation Deletion 

 



 

 

10. Data Files Operations 

10.1. Open 
Method 1: Double-click to open 

Use File Explorer to locate the data file you need to open, and you can open it directly. 
The prerequisite is that the data file is already associated with the software, valid only 
for. ihm and. atd. 

Method 2: Open via menu 

Menu: "Data -> Open". After locating the file, you can open it directly. 

 

Do you need to "Show original status"? 

By using the menu option "View -> Show original status", you can control the state 
when opening the data file. If "Show original status" is checked, the current analysis 
model will be ignored, and the file will open according to the last saved state, displaying 
the original series and restoring the annotation content. 

If "Show original status" is not checked, the data file will open using the current 
analysis model, displaying the series according to the format of the analysis model. If 
the analysis model contains tags that are not included in the data file, those tags will not 
generate series and will trigger a yellow warning. In this mode, the annotation content 
will not be restored. 

Reference: 

Comparison of the effects of "Show original status". 

10.2. Save 
If the displayed content or format changes, you are allowed to save it back to the 
original file. Note: Some annotations cannot be saved. 

  

https://hiddenmap.cn/files/video/00%20%E6%8A%80%E5%B7%A7/V2.0%20Ana%E6%98%AF%E5%90%A6%E5%8A%A0%E8%BD%BD%E5%8E%9F%E6%98%BE%E7%A4%BA%E7%8A%B6%E6%80%81%E7%9A%84%E6%95%88%E6%9E%9C%E5%AF%B9%E6%AF%94.mp4
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10.3. Save As and Export 
The menu: "Data -> Save as..." allows you to open Save As and Export. 

 
Figure 10.1 Data file Save As Page 

When selecting the save path, the file extension helps distinguish the saved file formats. 
This software supports two save formats: .ihm and .csv. 

.ihm is the data file save format for this software, which includes channel, tag 
configuration, annotation information, and data sections. 

The .csv format is a universal data table format that includes only tag names, time, and 
data content. The time axis can have multiple options, and the tag range can also be 
freely selected. 

The time base is the time interval between output points, including three modes: Auto, 
At signal change, and Manual. 

 Auto: 

It will automatically determine the optimal value based on the tag type and the number 
of external channels involved. 

 At signal change: 

With no fixed time base, an output record will be generated whenever there is a change 
in the selected tag values. If the selected tag changes slowly, it can significantly reduce 
the number of output records. If the selected tags include data that may change with 
each sampling, it could significantly increase the number of output records. 

 Manual: 

The user determines the calculation interval. If the output interval is greater than the 
sampling interval, some details may be overlooked. 
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Figure 10.2 CSV Format Export Options 

"Partial Save" can be used to export a portion of the data content. The operation method 
is as follows: use the Marker function to select the area to be saved, then go to this page, 
choose the save path, channels, and other details, and check "Partial Save" to achieve 
partial saving. After exporting, do not immediately open the newly created file. 

"Relative" will export the time difference relative to the trigger record, measured in 
seconds and accurate to milliseconds. 

10.4. Quick View Function 
The Quick View function allows for fast viewing of the current file directory. The 
interface is as follows: 

 
Figure 10.3 Quick View 

Clicking  will read the waveform files in the current file directory. After the update, 
the first file in the list will open and be displayed. 

The left and right arrows are used to switch between files in the list. The dropdown box 
can also be used for quick file opening. 
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10.5. Data Files Connection 
Method 1: Connect next 

Directly search for the next connected file in the current file's directory and connect the 
waveforms. A vertical dashed line will indicate the connection (you can show or hide 
the file connection line through the menu "View -> Options"). 

 
Figure 10.4 Illustration of Sequential File Connection 

You can perform this operation through the menu: "Data -> Multi files -> Connect next". 

You can also use the shortcut button  or the keyboard shortcut Ctrl+N to perform 
this operation. 

Method 2: Connect previous 

You can perform this operation through the menu: "Data -> Multi files -> Connect 
previous". You can also use the keyboard shortcut Ctrl+P to perform this operation. 

Method 3: Open multi 

Multiple matching data files can be connected in chronological order, even if they are 
not adjacent, and presented on a single graph. 
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Figure 10.5 Illustration of Multi-File Connection 

You can perform this operation through the menu: "Data -> Multi files -> Open multi". 
You can also use the keyboard shortcut Ctrl+H to perform this operation. 

 

No matter which way you connect them, the merged file will be named after the first file. 
When you click save, you will be prompted to save it as a new merged file. The merged 
file behaves like a single file and no longer has a vertical dashed line. 

10.6. Merge 
Please Open multi-file and then save them. 
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10.7. Save the Picture 
The picture can be copied and saved. 

Right-click on the picture to access the "Save Picture" and "Copy Picture" buttons, 
allowing you to save or copy the currently displayed content, as shown below: 

 
Figure 10.6 Illustration of Saving the Current Display Area 

In the top edit menu, in addition to the save and copy functions mentioned above, there 
is a "Copy full" feature that allows you to copy the entire picture, even beyond the 
window's range. The effect is as follows (due to space limitations, the lower part of the 
content has been cut off): 
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Figure 10.7 Illustration of the Saving Long Picture 

10.8. Power waveform file 
The power system waveform file (COMTRADE format) is a commonly used fault 
recording file in the power system. 

This software supports waveform files that comply with the IEEE Std C37.111-1999, 
2013 standard and supports: CFG and. DAT (binary format only) files are not 
supported .HDR,. INF, .CFF files. Time zone information in the 2013 standard is not 
supported. 

By After opening the CFG file, the menu "Data" will display the content of "Power 
System Analysis": 
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Figure 10.8 Automatic appearance of power menu 

By displaying the primary value, it is possible to switch between primary and secondary 
values and automatically change the units of voltage and current. 

Through "Power Harmonic Analysis", the harmonic analysis window can be opened to 
perform real-time harmonic analysis on the selected variables and time periods. 

 
Figure 10.9 Schematic diagram of harmonic analysis 



 

 

11. Fast Fourier analysis 

By using fast Fourier analysis, various frequency components in the waveform can be 
viewed. Open the data file and create the expression variables that need to be viewed or 
analyzed (drag and drop or create in the bottom table). Then, enter the window through 
the menu: "Tools" - "Fast Fourier Analysis" (automatically opens the first selected 
variable). Select the curve to be analyzed on the main interface, use a ruler to select the 
time window for analysis, and you can see the spectral distribution in real-time in the 
Fourier analysis window. 

 
Figure 11.1 Open the data file, select variables and time periods 

 
Figure 11.2 Fourier analysis interface 

The frequency range to be viewed can be modified through the "maximum frequency" 
input box. Click on the frequency curve with the mouse to view the corresponding 
frequency and amplitude. 

Select the box with the mouse in the X direction to view details: 



Data Files Operations 

 43 User Manual V3.10.0 04/2025 
 

 
Figure 11.3: Details of Frequency Domain Curve 

By using the Fast Fourier option, you can adapt to their desired preprocessing window 
and specify the content and format of the output. 

 
Figure 11.4: Fast Fourier options 

 



 

 

12. Channel Offset 

12.1. Function Description 
If users need to align the series of different channels at a specific time point, for 
example: there are two PLCs driving two moving carts, and they need to compare their 
acceleration and positioning for consistency, one channel's time can be offset to align 
the starting points of acceleration for both PLCs, allowing for comparison of whether 
the series coincide. 
The two series below show the changes in effects before and after adjusting the channel 
offset: 

 
Figure 12.1 Data Timestamps of Two Channels Being Exactly Aligned 

 
Figure 12.2 The Effect After a 1-second Offset Applied to PLC2 
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12.2. Channel Offset Setting Method 
Select a channel on the left tree diagram, right-click on the channel name, and you can 
access the channel offset menu: 

 

Figure 12.3 Method of Change Channel Offset 

You can modify the channel's offset time, which can be positive or negative, in units of 
ms or s. You can also clear the offset. 

The offset time is stored in the layout file. 

Channels with a time offset set will have their names bolded and prefixed with [T]. In 
the channel information, you can also see the bolded "Time Offset": 

 

Figure 12.4 Status of Channels with Time Offsets 



 

 

13. Extended Analysis 

13.1. Function Description 
Through the extended analysis function, users can launch an external program for 
further analysis of the current data file. 

13.2. Setting Method 
Set it up via the menu: "View -> Options". If this feature is enabled, a button labeled 
"Ext..." will appear on the main interface for quick operations. 

Use the "Select..." button to choose the external analysis software. 

When launching the analysis software, you can pass two parameters: the current data 
file name and the pointer time of the mouse click (refer to the demo software for 
parameter parsing methods). 

 

Figure 13.1 Setting Interface 
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13.3. Extended Analysis Effect Demonstration 

 

Figure 13.2 Extended Analysis Effect 
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14. Shortcut 
Category Function Shortcut 

Data 
Operations 

Single file: Open Ctrl+O 
Single file: Save Ctrl+S 
Single file: Save as Ctrl+F12 
Multi-file: Connect next Ctrl+N 
Multi-file: Connect previous Ctrl+P 
Multi-file: Open multi-file Ctrl+H 
Quick view: List update Ctrl+Shift+2 
Quick view: Previous file Ctrl+Shift+3 
Quick view: Next file Ctrl+Shift+4 
Search: Backward search Ctrl+Shift+B 
Search: Forward search Ctrl+Shift+F 
Check channels Ctrl+Q 

Model 
Operations 

New Ctrl+Shift+N 
Open Ctrl+Shift+O 
Save Ctrl+Shift+S 
Save As Ctrl+Shift+F12 

Series 
Operations 

Reset X Ctrl+X 
Reset Y Ctrl+Y 
Zoom out Ctrl+1 
Fit screen Ctrl+A 
Expression tags settings Ctrl+T 
Copy picture Ctrl+K 
Copy full Ctrl+L 
Save the picture Ctrl+R 

Others Open Help file F1 
Exit the program Alt+F4 

 



 

 

15. Frequently Asked Questions (FAQ) 

15.1. How to import data into Excel? 
Save the data file as a .csv file to open it directly with spreadsheet software. 

 

15.2. How to merge multiple waveform files? 
Perform the multi-file connection operation, and then save. 

15.3. Software interface display issues, including incomplete font 
rendering. 

Please adjust the scaling and layout options in the Windows system to the recommended 
values: 

WIN10 
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WIN11 
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15.4. The window shows a big red "X"; what should I do? 
The display crash shown in the picture below has been largely avoided by the software, 
but it cannot be completely eliminated. The common cause is data type errors that can't 
be detected during recording, leading to extreme values being collected, which causes 
the display controls to crash. 

For example: when we collect tags using DB1.0 and the PLC has a DINT, which is a 
32-bit tag, if the recording software uses DOUBLE for collection, it may collect the 
following 32 bits as well, potentially causing an error (though this does not necessarily 
cause an error). 

So, if you encounter this situation, please first carefully verify the data types. 

 
 



 

 

Appendix 1 Rules of Expression Tags and Descriptions of 
Functions 

1. Rule Description 
 Conversion relationships when performing mixed operations with logic and numeric 

values: 
 Numeric 0 <-> Boolean False 
 Non-zero numeric values -> Boolean True 
 Boolean True -> Numeric 1 

 The software will first attempt to convert the constant to a long integer; if the conversion 
fails, it will be converted to double precision. If the constant has a decimal point, it will 
be converted to double precision; if it does not have a decimal point, it will be converted 
to a long integer. 

 When performing mixed operations between integer and non-integer values, they will be 
converted to double precision before calculation. Be aware of potential precision loss. 

 Some operations require non-floating-point or double precision parameters (please 
follow the instructions). 

 Tag reference format: [0:2] 

 ':' is a type connector symbol, ':' represents a numerical value, '.' represents a bool, 
and '_' represents a string. 

 the part before ":" is the channel number  

 the part after ":" is the number of the variable of this type. 

 Names and functions are case-insensitive. 

 When a dynamic calculation encounters an error, it will return a value of 0 without 
interrupting the calculation. 

 String type is not currently supported. 

 Other Rules: 
Serial
 Num

ber 
Rule Correct Wrong 

1 Fuzzy continuous operators are 
not supported. 1+(-3) 1+-3 

2 
When "-" is preceded by "(" or 
",", it will be recognized as a 
negative sign. 

-(1+2)， 
Max(1,-2) 1>-2 

3 "*"should not be ignored 3*max(1,2) 3max(1,2) 

2. Supported Operators and Their Precedence 
Preced

ence 
Operat

ors 
Name or Meani

ng Usage Format 
Associativ
e Directio

n 
Description 

1 () Parentheses (Expression) / Function Nam
e(Parameter list) 

Left to Ri
ght  

2 
- Negative sign o

perator -Expression 
Right to 
Left 

Unary operator 

! Logical NOT op
erator !Expression Unary operator 

3 / Division Expression/Expression Left to Ri Binary operator 
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Preced
ence 

Operat
ors 

Name or Meani
ng Usage Format 

Associativ
e Directio

n 
Description 

* Multiplication Expression*Expression ght Binary operator 

% Remainder (Mod
ulus) 

Int Expression*Int Expression 
(Convert to Long for calcula
tion; the result is of Long t
ype.) 

Binary operator 

4 
+ Addition Expression+Expression Left to Ri

ght 
Binary operator 

- Subtraction Expression-Expression Binary operator 

6 

> Greater than Expression>Expression 

Left to Ri
ght 

Binary operator 

>= Greater than or 
equal to Expression>=Expression Binary operator 

< Less than Expression<Expression Binary operator 

<= Less than or eq
ual to Expression<=Expression Binary operator 

7 
== Equal to Expression==Expression Left to Ri

ght 
Binary operator 

!= Not equal to Expression!=Expression Binary operator 

8 & Bitwise AND Expression&Expression Left to Ri
ght Binary operator 

9 ^ Bitwise XOR Expression^Expression Left to Ri
ght Binary operator 

10 | Bitwise OR Expression|Expression Left to Ri
ght Binary operator 

15 , Comma 
Used for separating multiple
 parameters within a express
ion 

  

3. Function Description 
Name Function Parameter Description Return Value/Type 

abs Take the absolute value 
Count: 1 
Type: Any 
Range: Any 

Double-precision 
value 

acos acos(a): Returns the angle 
corresponding to a. 

Count: 1 
Type: Any 
Range: [-1, 1]. Values outside this 
range will be clamped, for example, 
1.5 will be clamped to 1. 

Angle: [0,180] 

asin asin(a): Returns an angle whose 
sine is a. 

Count: 1 
Type: Any 
Range: [-1, 1]. Values outside this 
range will be clamped, for example, 
1.5 will be clamped to 1. 

Angle: [-90,90] 

atan atan(a): Returns the angle whose 
tangent is a. 

Count: 1 
Type: Any 
Range: Any 

Angle: [-90,90] 

ceil 

ceil(a): Returns the smallest 
integer value greater than or equal 
to the specified double-precision 
floating-point number. 

Count: 1 
Type: Any 
Range: Any 

Double-precision 
value 

changing 
changing(a): If the status (or 
value) of a changed, return true; if 
not, return false. 

Count: 1 
Type: Any 
Range: Any 

bool 

cos cos(a): Returns the cosine value of 
a. 

Count: 1 
Type: Any (angle) 
Range: Any 

Double-precision 
value 
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Name Function Parameter Description Return Value/Type 

Diff 

Diff(a): Returns the differential of 
a. 
If the reference tag "a" belongs to 
the same external channel, the 
differentiation will be calculated 
according to the sampling 
frequency of that channel to 
ensure the stability of the 
differentiation. 
If the reference tag of a belongs to 
different external channels, the 
differentiation will be calculated 
according to the optimization 
frequency set by the expression 
channel. 

Count: 1 
Type: Any 
Range: Any 

Double precision 

exp Returns the specified power of e. 
Count: 1 
Type: Any 
Range: Any 

Double-precision 
value 

floor 

floor(a): Returns the maximum 
integer value less than or equal to 
the specified double-precision 
floating-point number. 

Count: 1 
Type: Any 
Range: Any 

Double-precision 
value 

getBit getBit(a,b): Get bit b from a. 

Count: 2 
Type: a can be any type (will be 
forcibly converted to long integer; if 
out of range, the result will be 0), b 
is an integer. 
Range: The value of b must be 
within the length range of a. 

bool 

IF IF(a,b,c): If a is true, return b. If 
not, return c. 

Count: 3 
Type: Any 
Range: Any 

If b or c is a bool, 
return a bool; if b or c 
is a float or double, 
return a double; for 
other types, return a 
long integer. 

Int Int(a,b): Returns the integral of a. 
If b is true, return 0. 

Count: 2 
Type: a can be any type, b is a bool. 
Range: Any 

Double precision 

limit limit(a,b,c): Limit a between b and 
c. 

Count: 3 
Type: Any 
Range: Any 

Double-precision 
value 

log log(a,b): Returns the logarithm of 
b when using the base a. 

Count: 2 
Type: Any 
Range: a,b>0 

Double-precision 
value 

ln ln(a): Returns the base 10 
logarithm of the specified number. 

Count: 1 
Type: Any 
Range: Any 

Double-precision 
value 

max max(a,b,c,...): Returns the largest 
of a,b,c... 

Count: >= 1 
Type: Any 
Range: Any 

Double-precision 
value 

min min(a,b,c,...）: Returns the 
minimum value of a,b,c... 

Count: >= 1 
Type: Any 
Range: Any 

Double-precision 
value 

PI Returns 3.1415926... None Double-precision 
value 

pow pow(a,b): Returns the b-th power 
of a. 

Count: 2 
Type: Any 
Range: Any 

Double-precision 
value 

round 
round(a): Rounds a to the nearest 
integer value and the midpoint 
value to the nearest even number. 

Count: 1 
Type: Any 
Range: Any 

Double-precision 
value 
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Name Function Parameter Description Return Value/Type 

RS 

Return the state value of the RS(a, 
b, c) trigger, where a is used for 
setting and b for resetting. When 
c=1, a takes priority; when c=0, b 
takes priority. 

Count: 3 
Type: bool 
Range: Any 

bool 

sAnd sAnd(a,b): Bitwise AND 
operation of a and b. 

Count: 2 
Type: non-floating point number or 
double precision number. 
Range: Any 

Long integer 

setBit 

Return the setting result of 
setBit(a, b, c). a is the number 
being modified, b is the bit index, 
and c is the target value of the bit. 

Count: 3 
Type: a is a non-floating point 
number or double precision number, 
b is an integer, and c is a bool. 
Range: The value of b must be 
within the length range of a. 

Long integer 

sin sin(a): Returns the sine of a. 
Count: 1 
Type: Any (angle) 
Range: Any 

Double-precision 
value 

sNot sNot(a): A is inversed bit by bit. 

Count: 1 
Type: non-floating point number or 
double precision number. 
Range: Any 

Long integer 

sOr sOr(a,b): Bitwise OR operation of 
a and b. 

Count: 2 
Type: non-floating point number or 
double precision number. 
Range: Any 

Long integer 

sqrt sqrt(a): Returns the square root of 
a. 

Count: 1 
Type: Any 
Range: Any 

Double-precision 
value 

sXor sXor(a,b): Bitwise XOR operation 
of a and b. 

Count: 2 
Type: non-floating point number or 
double precision number. 
Range: Any 

Long integer 

tan tan(a): Returns the tangent of a. 
Count: 1 
Type: Any (angle) 
Range: Any 

Double-precision 
value 

trunc 
trunc(a): Computes the integer 
portion of double precision 
floating-point number a. 

Count: 1 
Type: Any 
Range: Any 

Double-precision 
value 
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